Bug 28313 - Add street type to alternate address in OPAC
Summary: Add street type to alternate address in OPAC
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Lucas Gass
QA Contact: Testopia
URL:
Keywords:
: 12936 (view as bug list)
Depends on: 18112
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-10 20:48 UTC by Katrin Fischer
Modified: 2021-12-13 21:14 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
21.11.00,21.05.02


Attachments
Bug 28313: Add street type to alternate address in OPAC (4.81 KB, patch)
2021-05-10 21:18 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 28313: Add street type to alternate address in OPAC (4.85 KB, patch)
2021-05-13 11:28 UTC, David Nind
Details | Diff | Splinter Review
Bug 28313: Add street type to alternate address in OPAC (4.91 KB, patch)
2021-06-03 13:37 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 28313: (follow-up) Define roadtypes (1.15 KB, patch)
2021-06-21 08:54 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2021-05-10 20:48:11 UTC
Street type needs to be added to the alternate address block in the OPAC (see bug 18112).
Comment 1 Lucas Gass 2021-05-10 21:18:54 UTC
Created attachment 120813 [details] [review]
Bug 28313: Add street type to alternate address in OPAC

1. Add some values to the ROADTYPE authorized value
2. Go to PatronSelfRegistrationBorrowerUnwantedField and make sure B_streettype is NOT checked
3. Go the self reg form, no alternate address street type field
4. Apply patch
5. Check the self reg form, B_streettype should be there with all the options defined in ROADTYPE a.v.
6. Check the self modification form, B_street type should be there.
7. Make sure PatronSelfRegistrationBorrowerUnwantedField and PatronSelfModificationBorrowerUnwantedField hide the field correctly.
8. Make sure PatronSelfRegistrationBorrowerMandatoryField properly makes the field required.
Comment 2 Katrin Fischer 2021-05-10 21:53:04 UTC
That was pretty quick!
Comment 3 David Nind 2021-05-13 11:28:18 UTC
Created attachment 120919 [details] [review]
Bug 28313: Add street type to alternate address in OPAC

1. Add some values to the ROADTYPE authorized value
2. Go to PatronSelfRegistrationBorrowerUnwantedField and make sure B_streettype is NOT checked
3. Go the self reg form, no alternate address street type field
4. Apply patch
5. Check the self reg form, B_streettype should be there with all the options defined in ROADTYPE a.v.
6. Check the self modification form, B_street type should be there.
7. Make sure PatronSelfRegistrationBorrowerUnwantedField and PatronSelfModificationBorrowerUnwantedField hide the field correctly.
8. Make sure PatronSelfRegistrationBorrowerMandatoryField properly makes the field required.

Signed-off-by: David Nind <david@davidnind.com>
Comment 4 Katrin Fischer 2021-05-16 21:52:27 UTC
This includes strings, so probably will have to wait until after release.
Comment 5 Katrin Fischer 2021-06-03 13:37:13 UTC
Created attachment 121592 [details] [review]
Bug 28313: Add street type to alternate address in OPAC

1. Add some values to the ROADTYPE authorized value
2. Go to PatronSelfRegistrationBorrowerUnwantedField and make sure B_streettype is NOT checked
3. Go the self reg form, no alternate address street type field
4. Apply patch
5. Check the self reg form, B_streettype should be there with all the options defined in ROADTYPE a.v.
6. Check the self modification form, B_street type should be there.
7. Make sure PatronSelfRegistrationBorrowerUnwantedField and PatronSelfModificationBorrowerUnwantedField hide the field correctly.
8. Make sure PatronSelfRegistrationBorrowerMandatoryField properly makes the field required.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Katrin Fischer 2021-06-03 13:38:57 UTC
*** Bug 12936 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Druart 2021-06-21 08:54:31 UTC
Created attachment 122213 [details] [review]
Bug 28313: (follow-up) Define roadtypes

It's not necessarily defined at this point
Comment 8 Jonathan Druart 2021-06-21 10:05:41 UTC
Pushed to master for 21.11, thanks to everybody involved!
Comment 9 Kyle M Hall 2021-06-25 13:58:07 UTC
Pushed to 21.05.x for 21.05.02
Comment 10 Fridolin Somers 2021-07-10 01:47:06 UTC
Not pushed to 20.11.x since Bug 18112 is not