Bug 29965 - MARC preview for authority search results
Summary: MARC preview for authority search results
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Aleisha Amohia
QA Contact: Testopia
URL:
Keywords:
: 28247 (view as bug list)
Depends on: 12533
Blocks: 30131
  Show dependency treegraph
 
Reported: 2022-01-28 02:58 UTC by Aleisha Amohia
Modified: 2022-03-08 23:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
This enhancement makes the authority MARC preview modal available for the general authority search results.
Version(s) released in:
22.05.00


Attachments
Bug 29965: Preview MARC in authority search results (6.18 KB, patch)
2022-01-28 03:06 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 29965: Preview MARC in authority search results (6.20 KB, patch)
2022-01-31 00:03 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 29965: Preview MARC in authority search results (6.23 KB, patch)
2022-02-15 18:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 29965: Preview MARC in authority search results (6.28 KB, patch)
2022-02-18 17:35 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 29965: (follow-up) Move repeated JS to its own file (5.15 KB, patch)
2022-02-18 17:35 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 29965: (follow-up) Use a new class for the preview (4.19 KB, patch)
2022-02-18 17:35 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 29965: Preview MARC in authority search results (6.34 KB, patch)
2022-02-19 19:31 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 29965: (follow-up) Move repeated JS to its own file (5.21 KB, patch)
2022-02-19 19:31 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 29965: (follow-up) Use a new class for the preview (4.25 KB, patch)
2022-02-19 19:31 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 29965: (QA follow-up) Fix translation issue in moved JS code (1.21 KB, patch)
2022-02-19 19:31 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2022-01-28 02:58:04 UTC
Bug 12533 added a MARC preview for authority search results to the cataloguing authority finder plugin. This modal would be useful for the general authority search results as sometimes you want to compare authorities in the results list.
Comment 1 Aleisha Amohia 2022-01-28 03:06:11 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2022-01-28 11:49:45 UTC
I think for consistency the preview button should be in the Actions menu (see cataloging search).
Comment 3 Aleisha Amohia 2022-01-31 00:03:44 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2022-02-15 18:11:10 UTC
Created attachment 130635 [details] [review]
Bug 29965: Preview MARC in authority search results

This enhancement makes the authority MARC preview modal available for
the general authority search results.

To test:
1) Do a catalog search and edit a biblio record
2) Go to one of the authority tags (i.e. 1xx, 6xx, 7xx) and open the
authority finder plugin
3) Do an authority search
4) Click on one of the search result headings to open the modal. Confirm
it opens as expected.
5) Exit the biblio editor and go to Authorities
6) Do an authority search
7) Click on the Actions dropdown, then the MARC preview button,
to open the modal. Confirm it opens as expected.

Sponsored-by: Education Services Australia SCIS

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Nick Clemens 2022-02-18 17:35:41 UTC
Created attachment 130880 [details] [review]
Bug 29965: Preview MARC in authority search results

This enhancement makes the authority MARC preview modal available for
the general authority search results.

To test:
1) Do a catalog search and edit a biblio record
2) Go to one of the authority tags (i.e. 1xx, 6xx, 7xx) and open the
authority finder plugin
3) Do an authority search
4) Click on one of the search result headings to open the modal. Confirm
it opens as expected.
5) Exit the biblio editor and go to Authorities
6) Do an authority search
7) Click on the Actions dropdown, then the MARC preview button,
to open the modal. Confirm it opens as expected.

Sponsored-by: Education Services Australia SCIS

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 6 Nick Clemens 2022-02-18 17:35:44 UTC
Created attachment 130881 [details] [review]
Bug 29965: (follow-up) Move repeated JS to its own file

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 7 Nick Clemens 2022-02-18 17:35:47 UTC
Created attachment 130882 [details] [review]
Bug 29965: (follow-up) Use a new class for the preview

With previous patches everythign worked, however, clicking the heading in
authority search results now launched the preview instead of taking you to the
authority details

This patch uses a new class to launch the modal and conditionally applies it to
authority results as we expect different behaviours when searching from the popup
vs authority module

To test:
1 - Repeate previous tests, confirm they pass
2 - Search for authorities in the authority module
3 - COnfirm clicking on heading takes you to detail page for authority

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 8 Nick Clemens 2022-02-18 17:36:20 UTC
I added a bit, could use another QA eye
Comment 9 Katrin Fischer 2022-02-19 19:31:26 UTC
Created attachment 130907 [details] [review]
Bug 29965: Preview MARC in authority search results

This enhancement makes the authority MARC preview modal available for
the general authority search results.

To test:
1) Do a catalog search and edit a biblio record
2) Go to one of the authority tags (i.e. 1xx, 6xx, 7xx) and open the
authority finder plugin
3) Do an authority search
4) Click on one of the search result headings to open the modal. Confirm
it opens as expected.
5) Exit the biblio editor and go to Authorities
6) Do an authority search
7) Click on the Actions dropdown, then the MARC preview button,
to open the modal. Confirm it opens as expected.

Sponsored-by: Education Services Australia SCIS

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Katrin Fischer 2022-02-19 19:31:30 UTC
Created attachment 130908 [details] [review]
Bug 29965: (follow-up) Move repeated JS to its own file

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 11 Katrin Fischer 2022-02-19 19:31:34 UTC
Created attachment 130909 [details] [review]
Bug 29965: (follow-up) Use a new class for the preview

With previous patches everythign worked, however, clicking the heading in
authority search results now launched the preview instead of taking you to the
authority details

This patch uses a new class to launch the modal and conditionally applies it to
authority results as we expect different behaviours when searching from the popup
vs authority module

To test:
1 - Repeate previous tests, confirm they pass
2 - Search for authorities in the authority module
3 - COnfirm clicking on heading takes you to detail page for authority

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Katrin Fischer 2022-02-19 19:31:39 UTC
Created attachment 130910 [details] [review]
Bug 29965: (QA follow-up) Fix translation issue in moved JS code

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 13 Fridolin Somers 2022-02-24 07:44:56 UTC
This is great :D
Comment 14 Fridolin Somers 2022-02-24 08:05:48 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 15 Katrin Fischer 2022-03-08 23:04:10 UTC
*** Bug 28247 has been marked as a duplicate of this bug. ***