Bug 30532 - guided_reports.pl has a problem
Summary: guided_reports.pl has a problem
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P1 - high blocker (vote)
Assignee: Jonathan Druart
QA Contact: Tomás Cohen Arazi
URL:
Keywords: rel_21_11_candidate
: 30562 (view as bug list)
Depends on: 29957
Blocks: 30491
  Show dependency treegraph
 
Reported: 2022-04-13 17:12 UTC by Lucas Gass
Modified: 2022-04-25 21:17 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:
22.05.00,21.11.05


Attachments
Bug 30532: (bug 29957 follow-up) Fix '$cookie->value' (2.22 KB, patch)
2022-04-21 13:07 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 30532: (bug 29957 follow-up) Fix '$cookie->value' (2.27 KB, patch)
2022-04-21 13:34 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 30532: (bug 29957 follow-up) Fix '$cookie->value' (2.33 KB, patch)
2022-04-21 16:54 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Gass 2022-04-13 17:12:00 UTC
To recreate:

Go to: Home >  Reports > Create from SQL

Can't call method "value" on unblessed reference at /kohadevbox/koha/reports/guided_reports.pl line 80


Maybe caused by Bug 26019?
Comment 1 Owen Leonard 2022-04-13 18:34:50 UTC
This is basically the same issue as Bug 30525, though the problematic code is different than what I'd searched for to fix that bug.
Comment 2 David Cook 2022-04-19 04:56:46 UTC
*** Bug 30562 has been marked as a duplicate of this bug. ***
Comment 3 David Cook 2022-04-19 04:59:50 UTC
Based off Owen's comment, I'm guessing this depends on Bug 29957
Comment 4 Jonathan Druart 2022-04-21 13:07:15 UTC
Created attachment 133557 [details] [review]
Bug 30532: (bug 29957 follow-up) Fix '$cookie->value'

We got
 Can't call method "value" on unblessed reference at /kohadevbox/koha/opac/opac-messaging.pl line 86

$cookie can be an arrayref, we should retrieve the session id using
CGI->cookie('CGISESSID')
Comment 5 Nick Clemens 2022-04-21 13:34:50 UTC
Created attachment 133561 [details] [review]
Bug 30532: (bug 29957 follow-up) Fix '$cookie->value'

We got
 Can't call method "value" on unblessed reference at /kohadevbox/koha/opac/opac-messaging.pl line 86

$cookie can be an arrayref, we should retrieve the session id using
CGI->cookie('CGISESSID')

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 6 Tomás Cohen Arazi 2022-04-21 16:54:17 UTC
Created attachment 133593 [details] [review]
Bug 30532: (bug 29957 follow-up) Fix '$cookie->value'

We got
 Can't call method "value" on unblessed reference at /kohadevbox/koha/opac/opac-messaging.pl line 86

$cookie can be an arrayref, we should retrieve the session id using
CGI->cookie('CGISESSID')

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 7 Fridolin Somers 2022-04-21 23:42:25 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 8 Kyle M Hall 2022-04-22 18:29:25 UTC
Pushed to 21.11.x for 21.11.05
Comment 9 Victor Grousset/tuxayo 2022-04-25 21:17:14 UTC
> This is basically the same issue as Bug 30525, though the problematic code is different than what I'd searched for to fix that bug.

> [...]

> Go to: Home >  Reports > Create from SQL
> Can't call method "value" on unblessed reference at /kohadevbox/koha/reports/guided_reports.pl line 80

Andrew tested, 21.05.x not affected that kinda confirms it's due to bug 29957. No need to further backports then.