Bug 5728 - Adding note and manager_id fields to accountlines
Summary: Adding note and manager_id fields to accountlines
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
: 5752 (view as bug list)
Depends on:
Blocks: 5575
  Show dependency treegraph
 
Reported: 2011-02-10 01:10 UTC by Chris Cormack
Modified: 2013-12-05 20:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Patch from BibLibre (15.54 KB, patch)
2011-03-21 11:20 UTC, Julian Maurice
Details | Diff | Splinter Review
Rebased patch (15.51 KB, patch)
2011-03-23 08:10 UTC, Julian Maurice
Details | Diff | Splinter Review
correcting previous patch (15.62 KB, patch)
2011-04-06 14:12 UTC, Frederic Durand
Details | Diff | Splinter Review
Fix KohaVersion and database error (1.45 KB, patch)
2011-04-06 14:13 UTC, Frederic Durand
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-02-10 01:10:33 UTC
* manager_id contains the librarian that created the line
* note is a field that can be entered by the librarian
Comment 1 Julian Maurice 2011-03-21 11:20:25 UTC Comment hidden (obsolete)
Comment 2 Julian Maurice 2011-03-21 12:33:02 UTC
*** Bug 5752 has been marked as a duplicate of this bug. ***
Comment 3 Nicole C. Engard 2011-03-22 20:54:50 UTC
Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: Bug 5728: adding note and manager_id fields to accountlines
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging installer/data/mysql/updatedatabase.pl
CONFLICT (content): Merge conflict in installer/data/mysql/updatedatabase.pl
Failed to merge in the changes.
Patch failed at 0001 Bug 5728: adding note and manager_id fields to accountlines
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
nengard@debian:~/kohaclone$
Comment 4 Julian Maurice 2011-03-23 08:10:10 UTC Comment hidden (obsolete)
Comment 5 Frederic Durand 2011-04-06 14:12:56 UTC
Created attachment 3748 [details] [review]
correcting previous patch
Comment 6 Frederic Durand 2011-04-06 14:13:51 UTC
Created attachment 3749 [details] [review]
Fix KohaVersion and database error
Comment 7 Frederic Durand 2011-04-06 14:15:14 UTC
With two last patches testing is ok. Note and id_manager are well managed.
Comment 8 Chris Cormack 2011-04-09 09:31:39 UTC
Pushed, please test
Comment 9 Jared Camins-Esakov 2012-12-31 00:42:15 UTC
There have been no further reports of problems so I am marking this bug resolved.