Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers
Summary: Single branch mode should disable showing the branch name in front of all cal...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Kyle M Hall
QA Contact: Katrin Fischer
URL:
Keywords:
Depends on: 9995
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 23:08 UTC by Chris Cormack
Modified: 2015-06-04 23:24 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6886 - OPAC XSLT respecting single branch mode (5.76 KB, patch)
2012-08-05 21:35 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 6886 - Follow up for UNIMARC (2.46 KB, patch)
2012-08-05 21:45 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 6886 Follow up for NORMARC (2.98 KB, patch)
2012-08-05 22:00 UTC, Chris Cormack
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6886 - OPAC XSLT respecting single branch mode (5.83 KB, patch)
2012-08-09 14:30 UTC, Julian Maurice
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6886 - Follow up for UNIMARC (2.53 KB, patch)
2012-08-09 14:31 UTC, Julian Maurice
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6886 Follow up for NORMARC (3.05 KB, patch)
2012-08-09 14:32 UTC, Julian Maurice
Details | Diff | Splinter Review
Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers - Followup - Copies available for reference (4.06 KB, patch)
2013-01-04 18:41 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers (4.52 KB, patch)
2013-02-05 17:19 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers (4.38 KB, patch)
2013-03-11 15:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9744 - Add a column Fund name on the home page of acquisitions (12.58 KB, patch)
2013-03-19 13:32 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers (4.47 KB, patch)
2013-03-19 13:54 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers (6.43 KB, patch)
2013-04-08 13:14 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers - QA Followup (5.56 KB, patch)
2013-12-04 17:24 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers (6.52 KB, patch)
2013-12-21 11:06 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers - QA Followup (5.89 KB, patch)
2013-12-21 11:06 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-09-19 23:08:32 UTC
When you have single branch mode on, there is no need to display the branch name on every line of results.
Comment 1 Chris Cormack 2011-09-19 23:13:55 UTC
Currently we only use this syspref on the staff detail.tt page.

koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt:                    <td class="location">[% UNLESS ( singlebranchmode ) %][% itemloo.branchname %] [% END %]</td>

This bug would extend this functionality to the opac
Comment 2 Chris Cormack 2011-09-19 23:22:57 UTC
Hmm actually opac-results.tt is respecting the systempreference already
Comment 3 Chris Cormack 2011-09-19 23:23:53 UTC
Yep, its just the xslt pages for the opac not obeying the syspref, will fix now
Comment 4 Chris Cormack 2012-08-05 21:35:07 UTC Comment hidden (obsolete)
Comment 5 Chris Cormack 2012-08-05 21:45:04 UTC Comment hidden (obsolete)
Comment 6 Chris Cormack 2012-08-05 22:00:26 UTC Comment hidden (obsolete)
Comment 7 Chris Cormack 2012-08-05 22:01:51 UTC
Please test NORMAC and UNIMARC thoroughly
Comment 8 Julian Maurice 2012-08-09 14:30:41 UTC Comment hidden (obsolete)
Comment 9 Julian Maurice 2012-08-09 14:31:28 UTC Comment hidden (obsolete)
Comment 10 Julian Maurice 2012-08-09 14:32:14 UTC Comment hidden (obsolete)
Comment 11 Julian Maurice 2012-08-09 14:34:52 UTC
Tested the 3 XSLT on master with singleBranchMode ON, branches are displayed.
Tested the 3 XSLT with the patch with singleBranchMode ON, branches are not displayed

Tested with singleBranchMode OFF, with and without the patch, display doesn't change.

Ok.
Comment 12 Marcel de Rooy 2012-08-30 11:22:44 UTC
QA Comment:
Looks good to me.
Passed QA
Comment 13 Paul Poulain 2012-09-05 08:35:49 UTC
Patch pushed to master
Comment 14 Chris Cormack 2012-09-05 23:12:18 UTC
Pushed to 3.8.x will be in 3.8.5
Comment 15 Melia Meggs 2012-11-28 21:45:16 UTC
Does this patch only work for available items?

After applying the patch, we're seeing that the 'not for loan' items still show the branch name, but the 'available' items don't.  I don't think we really need to see the branch name on ANY of the items when single branch mode is on.

Before the patch, we had the branch name showing on all items in the search results.  After the patch, we have the branch name showing only on not for loan items.  It seems confusing to see it on some items and not on others.  

Can we make it hide the branch name regardless of status?
Comment 16 Kyle M Hall 2013-01-04 18:41:14 UTC Comment hidden (obsolete)
Comment 17 Owen Leonard 2013-02-05 17:19:25 UTC Comment hidden (obsolete)
Comment 18 Jonathan Druart 2013-03-11 13:51:27 UTC
Patch does not apply. Caused by bug 5079 which removes the "Copies available for reference" block.
Comment 19 Kyle M Hall 2013-03-11 15:08:31 UTC Comment hidden (obsolete)
Comment 20 jmbroust 2013-03-19 10:38:50 UTC
tested on sandbox, seems to work.
Comment 21 Paul Poulain 2013-03-19 13:32:22 UTC
Patch tested with a sandbox, by Broust <jean-manuel.broust@univ-lyon2.fr>
Comment 22 Paul Poulain 2013-03-19 13:32:43 UTC Comment hidden (obsolete)
Comment 23 Jonathan Druart 2013-03-19 13:51:22 UTC
This patch already exists on master. This last one is for 3.6 branch. This patch cannot be tested on a sandbox.
Comment 24 Jonathan Druart 2013-03-19 13:54:39 UTC Comment hidden (obsolete)
Comment 25 Jonathan Druart 2013-03-19 13:55:10 UTC
(In reply to comment #23)
> This patch already exists on master. This last one is for 3.6 branch. This
> patch cannot be tested on a sandbox.

Forget that, it is for master!
Comment 26 Katrin Fischer 2013-04-07 13:11:16 UTC
Why using a choose when an if would do?

+            <xsl:choose>
+              <xsl:when test="$singleBranchMode=0">
+                  <xsl:value-of select="items:homebranch"/>
+              </xsl:when>
+            </xsl:choose>
Comment 27 Katrin Fischer 2013-04-07 14:08:18 UTC
This can't be tested as on current master reference items (itemtype = not for loan) are no longer shown in the result list. I reported bug 9995 for that.
Comment 28 Kyle M Hall 2013-04-08 13:14:27 UTC Comment hidden (obsolete)
Comment 29 Nicole C. Engard 2013-07-15 17:03:14 UTC
What does the status of 'BLOCKED' mean?
Comment 30 Katrin Fischer 2013-07-15 17:58:45 UTC
BLOCKED was added to help testers to notice dependencies. Like this bug couldn't be tested before 9995 was fixed.
Comment 31 Katrin Fischer 2013-08-03 20:52:38 UTC
This works, but I am a bit torn on the <choose> constructs:

+            <xsl:choose>
+              <xsl:when test="$singleBranchMode=0">
+                  <xsl:value-of select="items:homebranch"/>
+              </xsl:when>
+            </xsl:choose>

This could be:

<xsl:if test="$singleBranchMode=0">
  <xsl:value-of select="items:homebranch"/>
</xsl:if>
Comment 32 Katrin Fischer 2013-08-17 09:23:55 UTC
Kyle, could you please take a look at my comment please? I am still torn if this is a fail, but it just doesn't look right to me :)
Comment 33 Kyle M Hall 2013-08-28 12:29:54 UTC
I was just replicating what other parts of the xslt was already doing. If you think the if is better ( which I imagine it is ) that's fine by me. Would you like to add a qa followup, or shall I?

(In reply to Katrin Fischer from comment #31)
> This works, but I am a bit torn on the <choose> constructs:
> 
> +            <xsl:choose>
> +              <xsl:when test="$singleBranchMode=0">
> +                  <xsl:value-of select="items:homebranch"/>
> +              </xsl:when>
> +            </xsl:choose>
> 
> This could be:
> 
> <xsl:if test="$singleBranchMode=0">
>   <xsl:value-of select="items:homebranch"/>
> </xsl:if>
Comment 34 Katrin Fischer 2013-08-28 14:19:04 UTC
Hi Kyle, please change the patch yourself, so I can test it.
Comment 35 Kyle M Hall 2013-12-04 17:24:57 UTC Comment hidden (obsolete)
Comment 36 Kyle M Hall 2013-12-04 17:26:30 UTC
Here's is the QA followup!

(In reply to Katrin Fischer from comment #34)
> Hi Kyle, please change the patch yourself, so I can test it.
Comment 37 Katrin Fischer 2013-12-21 11:06:31 UTC
Created attachment 23745 [details] [review]
[PASSED QA] Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers

Followup - Copies available for reference

Test plan: Enable singleBranchMode and  OPACXSLTResultsDisplay. Perform
a search in the OPAC which returns results containing not-for-loan
items. Before the patch these items will show their library in search
results loan items. After the patch there will be not be a library
listed, matching other items in results.

Signed-off-by jmbroust <jean-manuel.broust@univ-lyon2.fr>

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comments on second patch.
Comment 38 Katrin Fischer 2013-12-21 11:06:54 UTC
Created attachment 23746 [details] [review]
[PASSED QA] Bug 6886 - Single branch mode should disable showing the branch name in front of all callnumbers - QA Followup

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
Switching SingleBranchMode:

Tested with MARC21 and UNIMARC:
- "Don't allow" - branch is not shown in result list
- "Allow" - branch is shown for available items in result list

Changes are consistent over all 3 MARC flavours.
Comment 39 Galen Charlton 2014-01-06 16:34:14 UTC
Pushed to master, along with a follow-up that removes a redundant check on singleBranchMode.  Thanks, Kyle!

This patch does not update the XSLT for the Bootstrap theme, but I think that can be relegated to bug 11310.
Comment 40 Fridolin Somers 2014-02-18 08:36:26 UTC
3 new patches pushed to 3.14.x, will be in 3.14.4.