Bug 6994 - 'No budget defined' showing up although budgets and funds are defined
Summary: 'No budget defined' showing up although budgets and funds are defined
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.6
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Target Milestone: ---
Assignee: Katrin Fischer
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 5072
  Show dependency treegraph
 
Reported: 2011-10-09 22:40 UTC by Katrin Fischer
Modified: 2013-12-05 20:01 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot of error message (19.48 KB, image/png)
2011-10-09 22:40 UTC, Katrin Fischer
Details
Bug 6994: Wrong 'no budget defined' alert (2.65 KB, patch)
2011-10-24 19:12 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6994: Wrong 'no budget defined' alert (2.75 KB, patch)
2011-10-28 18:37 UTC, Liz Rea
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-10-09 22:40:40 UTC
Created attachment 5815 [details]
screenshot of error message

You can't create any orders unless you first define a budget and a fund. 

Information to reproduce:
- budget and funds are defined
- ordering in general works
- warning shows up when search for existing record from basket gives no results
Comment 1 Katrin Fischer 2011-10-09 22:41:11 UTC
Note: CCL parsing error showed up because I had searched for '5)' - known problem.
Comment 2 Katrin Fischer 2011-10-24 19:12:06 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2011-10-28 18:37:01 UTC
Created attachment 6101 [details] [review]
Bug 6994: Wrong 'no budget defined' alert

When ordering from an existing record the 'no budgets and funds defined' error
message was shown below the result list.

To test:
A) No budgets defined for this user and library
Basket summary page shows a warning instead of the link for creation
of orders.

B) Budgets and funds are properly defined for this user and library
Basket summary page shows links for order creation.
Before patch: A search for an existing record had the alert at the bottom
of the search result list.
After patch: The links for creation of orders are shown instead.

Signed-off-by: Liz Rea <lrea@nekls.org>
Verified A and B.
Comment 4 Ian Walls 2011-11-06 08:34:29 UTC
Implements this check consistently, using the same structure as acqui/basket.pl  Use of GetMember instead of GetMemberDetails keeps it as lean as possible.  Marking as Passed QA.
Comment 5 Paul Poulain 2011-11-06 10:45:18 UTC
Patch pushed, please test
Comment 6 Jared Camins-Esakov 2012-05-23 12:52:41 UTC
This fix was included in the 3.6.x branch prior to 3.6.4.