Bug 7074 - Show subtitle, part and number of a record in list of checkins
Summary: Show subtitle, part and number of a record in list of checkins
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Katrin Fischer
QA Contact: Bugs List
URL:
Keywords:
: 9379 (view as bug list)
Depends on: 11529
Blocks: 23701 3550
  Show dependency treegraph
 
Reported: 2011-10-20 21:18 UTC by Nicole C. Engard
Modified: 2020-01-06 20:24 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.11.00


Attachments
Bug 7074: Show subtitle, part and number of a record in list of checkins (1.51 KB, patch)
2019-08-10 18:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 7074: Show subtitle, part and number of a record in list of checkins (2.62 KB, patch)
2019-08-12 22:03 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 7074: Show subtitle, part and number of a record in list of checkins (2.67 KB, patch)
2019-08-13 13:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 7074: Show subtitle, part and number of a record in list of checkins (2.72 KB, patch)
2019-09-30 14:14 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 7074: (QA follow-up) Deal with multiple fields (1.89 KB, patch)
2019-09-30 14:14 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-10-20 21:18:44 UTC
It would be nice to have the keyword mapping carry over to the checkin and checkout listings since subtitle doesn't show on these screens.
Comment 1 Katrin Fischer 2011-10-21 00:05:58 UTC
+1 One of my libraries asked for this too. They have lots of school books where the volume number is important to see what it actually is. It would be nice if there was a possiblity to add this to the checkout and checkin lists.
Comment 2 Owen Leonard 2011-11-11 20:26:27 UTC
I don't know how you would do this for circulation.pl without slowing things down. The method for getting the subtitle involves pulling quite a lot of data, and you'd have to do it for each title the patron had checked out:

        my $record       = GetMarcBiblio($it->{'biblionumber'});
        my $fw           = GetFrameworkCode($it->{'biblionumber'});
        my $subtitle     = GetRecordValue('subtitle', $record, $fw);

Is there a better way?
Comment 3 Katrin Fischer 2011-11-12 08:08:46 UTC
It could be an option with a warning, only working if you have mappings with a new keyword, perhaps.
Comment 4 Owen Leonard 2013-01-11 16:57:54 UTC
*** Bug 9379 has been marked as a duplicate of this bug. ***
Comment 5 Katrin Fischer 2019-03-14 07:08:04 UTC
The patches from 11529 might make this more feasable performance wise.
Comment 6 Katrin Fischer 2019-08-10 17:50:41 UTC
I've verified that the information already shows on the checkout screens, this leaves the checkin :)
Comment 7 Katrin Fischer 2019-08-10 18:20:30 UTC
Created attachment 92134 [details] [review]
Bug 7074: Show subtitle, part and number of a record in list of checkins

Shows the subtitle, part and number information from the biblio tables
as part of the title in the list of checkins (for MARC21: 245$b$n$p).

To test:
- Apply patch
- Catalog a record with 245$a$b$n$p filled out
- Check the item out to any patron
- Verify that in the list of checkouts the information shows
- Check out any other items with different 245
- Verify information is correct
- In a new tab, return the items
- Verify that in the list of checkins the information now
  matches the checkouts list
Comment 8 Katrin Fischer 2019-08-12 11:55:44 UTC
Missing the template changes - going to resubmit once fixed.
Comment 9 Katrin Fischer 2019-08-12 22:03:40 UTC
Created attachment 92164 [details] [review]
Bug 7074: Show subtitle, part and number of a record in list of checkins

Shows the subtitle, part and number information from the biblio tables
as part of the title in the list of checkins (for MARC21: 245$b$n$p).

To test:
- Apply patch
- Catalog a record with 245$a$b$n$p filled out
- Check the item out to any patron
- Verify that in the list of checkouts the information shows
- Check out any other items with different 245
- Verify information is correct
- In a new tab, return the items
- Verify that in the list of checkins the information now
  matches the checkouts list
Comment 10 Katrin Fischer 2019-08-12 22:04:16 UTC
Fixed patch attached!
Comment 11 Owen Leonard 2019-08-13 13:45:18 UTC
Created attachment 92177 [details] [review]
Bug 7074: Show subtitle, part and number of a record in list of checkins

Shows the subtitle, part and number information from the biblio tables
as part of the title in the list of checkins (for MARC21: 245$b$n$p).

To test:
- Apply patch
- Catalog a record with 245$a$b$n$p filled out
- Check the item out to any patron
- Verify that in the list of checkouts the information shows
- Check out any other items with different 245
- Verify information is correct
- In a new tab, return the items
- Verify that in the list of checkins the information now
  matches the checkouts list

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 12 Nick Clemens 2019-09-30 14:14:23 UTC
Created attachment 93263 [details] [review]
Bug 7074: Show subtitle, part and number of a record in list of checkins

Shows the subtitle, part and number information from the biblio tables
as part of the title in the list of checkins (for MARC21: 245$b$n$p).

To test:
- Apply patch
- Catalog a record with 245$a$b$n$p filled out
- Check the item out to any patron
- Verify that in the list of checkouts the information shows
- Check out any other items with different 245
- Verify information is correct
- In a new tab, return the items
- Verify that in the list of checkins the information now
  matches the checkouts list

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 13 Nick Clemens 2019-09-30 14:14:32 UTC
Created attachment 93264 [details] [review]
Bug 7074: (QA follow-up) Deal with multiple fields

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 14 Martin Renvoize 2019-10-01 10:52:25 UTC
Nice work!

Pushed to master for 19.11.00