Bug 7183 - consistency of displays
Summary: consistency of displays
Status: RESOLVED DUPLICATE of bug 22279
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 7119
  Show dependency treegraph
 
Reported: 2011-11-06 06:21 UTC by Paul Poulain
Modified: 2019-03-14 07:11 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2011-11-06 06:21:42 UTC
There is no consistency for most displays in Koha. Sometimes, patron information is displayed
John, Doe +123 45 67 89, New York
sometimes
Doe, John, New York Adult
Sometimes
<b>John Doe</b>
Adult, New York
...

Template Toolkit can help us having a consistent display: we should define basic objects and how they are displayed is managed in a specific include, ensuring consistency.
A first list of objects:
* biblio
* biblio+item (location, without availability, like what is displayed in item bulkmodification, cart,...)
* biblio+item (location and availability like what is displayed in circulation/hold pages)
* patron
Comment 1 Marc Véron 2015-12-20 16:46:29 UTC
Still valid?
Comment 2 Katrin Fischer 2019-03-14 07:11:38 UTC

*** This bug has been marked as a duplicate of bug 22279 ***