Bug 9555 - Template files contain single quote strings
Summary: Template files contain single quote strings
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Jonathan Druart
QA Contact:
URL:
Whiteboard:
Keywords:
: 9713 9714 (view as bug list)
Depends on: 8942
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-06 15:32 UTC by Jonathan Druart
Modified: 2014-05-26 21:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9555: Template files contain single quote strings (5.31 KB, patch)
2013-02-06 15:37 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 9555: Template files contain single quote strings (5.37 KB, patch)
2013-02-08 16:55 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9555: Template files contain single quote strings (3.73 KB, patch)
2013-02-19 08:23 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 9555: Template files contain single quote strings (3.85 KB, patch)
2013-02-27 07:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 9555: Another template contains single quotes in a js string (1.17 KB, patch)
2013-03-08 05:43 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 9555: Another template contains single quotes in a js string (1.21 KB, patch)
2013-03-08 16:44 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9555: Another template contains single quotes in a js string (1.22 KB, patch)
2013-03-11 09:34 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-02-06 15:32:55 UTC

    
Comment 1 Jonathan Druart 2013-02-06 15:37:57 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2013-02-08 16:55:08 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-02-19 08:23:23 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2013-02-19 08:23:44 UTC
rebased patch.
Comment 5 Owen Leonard 2013-02-26 17:38:38 UTC
*** Bug 9714 has been marked as a duplicate of this bug. ***
Comment 6 Owen Leonard 2013-02-26 17:38:53 UTC
*** Bug 9713 has been marked as a duplicate of this bug. ***
Comment 7 Katrin Fischer 2013-02-27 07:29:30 UTC Comment hidden (obsolete)
Comment 8 Jared Camins-Esakov 2013-03-01 00:16:23 UTC
This patch has been pushed to master.
Comment 9 Chris Cormack 2013-03-08 05:43:26 UTC Comment hidden (obsolete)
Comment 10 Kyle M Hall 2013-03-08 16:44:12 UTC Comment hidden (obsolete)
Comment 11 Jonathan Druart 2013-03-11 09:33:49 UTC
QA comment:
The xt/single_quotes.t test failed before this patch

#   Failed test 'Files do not contain single quotes _(' '
#   at xt/single_quotes.t line 39.
# Files list: 
# manage.tt:                 return GB_showCenter(_('Export patron cards'), "/cgi-bin/koha/patroncards/print.pl?" + getstr, 700, 800);
# Looks like you failed 1 test of 1.
xt/single_quotes.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 

Now all tests pass.

Marked as Passed QA.
Comment 12 Jonathan Druart 2013-03-11 09:34:04 UTC
Created attachment 16015 [details] [review]
Bug 9555: Another template contains single quotes in a js string

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 13 Jared Camins-Esakov 2013-03-11 11:41:14 UTC
This patch has been pushed to master.
Comment 14 Chris Cormack 2013-04-24 09:02:58 UTC
Pushed to 3.10.x will be in 3.10.6