Bug 15916 - Regression: Many tables' sorting broken by JavaScript error
Summary: Regression: Many tables' sorting broken by JavaScript error
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL: /cgi-bin/koha/circ/pendingreserves.pl
Keywords:
: 15915 (view as bug list)
Depends on:
Blocks: 15925
  Show dependency treegraph
 
Reported: 2016-02-25 16:38 UTC by Owen Leonard
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15916: Datatables - buttons area should be defined (1.47 KB, patch)
2016-02-29 08:41 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15916: Datatables - buttons area should be defined (1.57 KB, patch)
2016-02-29 08:55 UTC, Marcel de Rooy
Details | Diff | Splinter Review
[PASSED QA] Bug 15916: Datatables - buttons area should be defined (1.60 KB, patch)
2016-02-29 22:49 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-02-25 16:38:49 UTC
There is a JavaScript error on the holds to pull page which breaks table sorting. git blames Bug 15285, "Update common files."
Comment 1 Owen Leonard 2016-02-26 13:22:38 UTC
The same issue affects:

 circ/waitingreserves.pl
 circ/reserveratios.pl
 patron_lists/lists.pl
 virtualshelves/shelves.pl
 acqui/invoices.pl

...and presumably more.
Comment 2 Owen Leonard 2016-02-26 13:37:28 UTC
Broken js on patron_lists/list.pl prevents patrons from being searched and thus prevents them from being added to a patron list.
Comment 3 Jonathan Druart 2016-02-29 08:41:13 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2016-02-29 08:55:24 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2016-02-29 22:49:03 UTC
Created attachment 48479 [details] [review]
[PASSED QA] Bug 15916: Datatables - buttons area should be defined

Commit 243b797dd11bc0ac1f475195ab765ffbf2220f8b
    Bug 15285: Update common files

Set 'B' to the default dom of Datatable constructor.
This cannot work if there is no button defined.

This patch defined an empty 'buttons' param for this constructor, DT
does not raised an error anymore when initialising.

Test plan:
Confirm that the tables on the following tables are not broken:
- circ/waitingreserves.pl
- circ/reserveratios.pl
- patron_lists/lists.pl
- virtualshelves/shelves.pl
- acqui/invoices.pl
And with datatables:
- circ/circulation.pl
- admin/currency.pl

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Brendan Gallagher 2016-03-02 00:51:33 UTC
pushed to master - should be in the May 2016 release.  Thanks!
Comment 7 Julian Maurice 2016-03-07 08:11:47 UTC
Does not concern stable versions, status changed to RESOLVED
Comment 8 Jonathan Druart 2016-03-08 10:06:48 UTC
*** Bug 15915 has been marked as a duplicate of this bug. ***