Bug 27451 - Split opac_news.lang into two distinct fields for location and language
Summary: Split opac_news.lang into two distinct fields for location and language
Status: RESOLVED DUPLICATE of bug 24387
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Keywords:
Depends on: 22544
Blocks: 9081 24346 26801 22663 24220 24221 24223 24224 24766
  Show dependency treegraph
 
Reported: 2021-01-16 16:32 UTC by Josef Moravec
Modified: 2021-07-12 08:27 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2021-01-16 16:32:02 UTC

    
Comment 1 Jonathan Druart 2021-01-20 09:50:31 UTC
Why? Can you explain a bit please?
Comment 2 Josef Moravec 2021-01-20 10:07:27 UTC
The 'lang' field now holds information about language and display location. These two string are concatenated by '_'. So data in lang field are not atomic. This leads to not very flexible design...
Comment 3 Katrin Fischer 2021-02-06 18:57:23 UTC
I think Josef is right about the cleaner design and it will also make it a little nicer to add an 'all languages' like I think we really should have for the logo and such. It also makes reporting and querying on the data nicer.
Comment 4 Jonathan Druart 2021-03-11 09:29:42 UTC
Shouldn't we actually implement the same behaviour and UI than for the notice templates?
https://snipboard.io/Ol8fZY.jpg

We would have a short list of the different block/content/news to edit, then a form with a list of the languages (vs the long ugly dropdown list we have now).
It will also add the ability to have a default value.
Comment 5 Martin Renvoize 2021-03-11 09:31:42 UTC
100% agree with that approach Jonathan :)
Comment 6 Jonathan Druart 2021-07-12 08:27:08 UTC
Done on bug 24387.

*** This bug has been marked as a duplicate of bug 24387 ***