Bug 5432 - Duplicate patron feature
Summary: Duplicate patron feature
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Christophe Croullebois
QA Contact: Bugs List
URL: http://wiki.koha-community.org/wiki/D...
Keywords:
: 2602 3475 (view as bug list)
Depends on:
Blocks: 5575
  Show dependency treegraph
 
Reported: 2010-11-24 16:03 UTC by Paul Poulain
Modified: 2013-12-05 20:06 UTC (History)
10 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (38.60 KB, patch)
2011-02-14 02:07 UTC, Chris Cormack
Details | Diff | Splinter Review
duplicated patron (47.10 KB, image/png)
2011-02-14 13:43 UTC, Nicole C. Engard
Details
follow-up patch, removing test string (1.57 KB, patch)
2011-03-01 21:08 UTC, Paul Poulain
Details | Diff | Splinter Review
Follow-up fix (2.37 KB, patch)
2011-03-28 17:19 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 5432 [Follow-up] Duplicate patron feature (1.68 KB, patch)
2013-03-26 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 5432 [Follow-up] Duplicate patron feature (1.71 KB, patch)
2013-04-02 23:32 UTC, David Cook
Details | Diff | Splinter Review
Bug 5432 [Follow-up] Duplicate patron feature (1.78 KB, patch)
2013-04-03 07:43 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2010-11-24 16:03:18 UTC
New button to duplicate patron card. A new form with the duplicated values will open up and when the librarian will put his cursor on a field, the value will be erased so that he can write what he wants. Then the librarian save the new card.
Comment 1 Chris Cormack 2011-02-14 02:07:51 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2011-02-14 13:43:17 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2011-02-14 15:32:15 UTC
This patch modifies members-toolbar.inc but not circ-toolbar.inc. If we want to cover all patron-related pages we need to add the same modification to both (although the reasons for maintaining two includes my no longer be valid, something for another bug).
Comment 4 Owen Leonard 2011-02-14 15:36:48 UTC
I think not carrying over the first name is correct behavior: You're duplicating the patron because you're creating a variation on that record, not a straight duplicate. For that reason, however, I think initials and other name should not carry over either--unless I misunderstand how these fields are used?
Comment 5 dev_patches 2011-02-14 16:18:45 UTC
Use case is adding a member of the same family the same day....
Not wanting to re-enter all the fields.
So have some kind of Help.
Remeber other names and initials are not really used in France. So maybe this was not seen as a problem for us.
Comment 6 Paul Poulain 2011-03-01 21:08:53 UTC Comment hidden (obsolete)
Comment 7 Paul Poulain 2011-03-01 21:09:43 UTC
pls sign-off
Comment 8 Chris Cormack 2011-03-05 07:26:27 UTC
Pushed please test
Comment 9 MJ Ray (software.coop) 2011-03-06 12:09:55 UTC
This bug is mentioned in:
Bug 5432 : (MT #4584b)Add duplicate support	for borrowers http://lists.koha-community.org/pipermail/koha-patches/2011-February/013846.html
Bug 5432 : (MT #4584b)Add duplicate	support for borrowers http://lists.koha-community.org/pipermail/koha-patches/2011-February/013959.html
Comment 10 Nicole C. Engard 2011-03-06 14:04:15 UTC
works lovely!
Comment 11 Nicole C. Engard 2011-03-07 18:21:01 UTC
*** Bug 3475 has been marked as a duplicate of this bug. ***
Comment 12 Owen Leonard 2011-03-28 17:08:09 UTC
*** Bug 2602 has been marked as a duplicate of this bug. ***
Comment 13 Owen Leonard 2011-03-28 17:19:21 UTC
circ-toolbar.inc should include the same modification so that all patron-related pages have the 'duplicate' button.
Comment 14 Owen Leonard 2011-03-28 17:19:50 UTC Comment hidden (obsolete)
Comment 15 Chris Cormack 2011-04-01 17:09:24 UTC
Follow up pushed, please test
Comment 16 MJ Ray (software.coop) 2011-04-04 08:09:57 UTC
This bug is mentioned in:
Follow-up fix for Bug 5432 -	Duplicate patron feature http://lists.koha-community.org/pipermail/koha-patches/2011-March/014291.html
Follow-up fix for Bug 5432 - Duplicate	patron feature http://lists.koha-community.org/pipermail/koha-patches/2011-March/014286.html
Comment 17 Julian Maurice 2011-04-05 12:01:51 UTC
The 'Sort 1' field value is not erased when I put my cursor on it. Is this behavior normal?
Comment 18 Katrin Fischer 2011-08-05 18:36:17 UTC
I can confirm the problem with the sort1 field on current master. I mark this reopened so this little bug doesn't get lost and can be addressed.
The feature itself works.
Comment 19 Paul Poulain 2012-02-15 16:16:00 UTC
Christophe, you've been randomly choosen to check if the problem is still here and provide a fix (see comment 17 and comment 18)
Comment 20 Owen Leonard 2013-03-26 14:16:45 UTC
The bug described in comment 17 still exists in master as of 3.12 beta1
Comment 21 Owen Leonard 2013-03-26 14:24:20 UTC Comment hidden (obsolete)
Comment 22 David Cook 2013-04-02 23:32:20 UTC Comment hidden (obsolete)
Comment 23 Jonathan Druart 2013-04-03 07:43:38 UTC
Add the behavior for sort2
Marked as Passed QA.
Comment 24 Jonathan Druart 2013-04-03 07:43:52 UTC
Created attachment 17154 [details] [review]
Bug 5432 [Follow-up] Duplicate patron feature

It is noted in Bug 5432 that during a duplicate operation one field,
'Sort1' does not automatically clear when the cursor moves into it. This
patch corrects this.

Edit a patron record to have data in the Sort1 and Sort2 fields. Perform
a duplicate operation on this patron and confirm that the Sort1 and
Sort2 fields show the information from the original patron record. When
you click on each field the contents should disappear.

Signed-off-by: David Cook <dcook@prosentient.com.au>

Works as described.

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 25 Jared Camins-Esakov 2013-04-03 11:16:45 UTC
The latest patch has been moved onto bug 9981, and I am closing this bug.