Bug 22196 - Clean up Mana KB administration template
Summary: Clean up Mana KB administration template
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact: Josef Moravec
URL:
Whiteboard:
Keywords:
: 22202 22244 (view as bug list)
Depends on: 17047
Blocks: 22198
  Show dependency treegraph
 
Reported: 2019-01-23 17:06 UTC by Owen Leonard
Modified: 2019-02-11 13:43 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 22196: Clean up Mana KB administration template (15.54 KB, patch)
2019-01-23 19:10 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22196: Clean up Mana KB administration template (16.45 KB, patch)
2019-01-24 14:56 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22196: Clean up Mana KB administration template (18.26 KB, patch)
2019-01-24 15:43 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22196: Clean up Mana KB administration template (18.28 KB, patch)
2019-01-27 10:00 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 22196: (QA follow-up) Fix some typo (1.14 KB, patch)
2019-01-27 10:00 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 22196: Clean up Mana KB administration template (18.31 KB, patch)
2019-01-28 20:57 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22196: (QA follow-up) Fix some typo (1.19 KB, patch)
2019-01-28 20:58 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22196: (QA follow-up) Fix some more typo (1.65 KB, patch)
2019-01-28 20:58 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2019-01-23 17:06:15 UTC
There are some markup and content corrections to be made to the Mana KB administration template.
Comment 1 Owen Leonard 2019-01-23 19:10:20 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2019-01-24 12:39:26 UTC
*** Bug 22202 has been marked as a duplicate of this bug. ***
Comment 3 Owen Leonard 2019-01-24 14:56:04 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2019-01-24 15:43:54 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2019-01-27 10:00:16 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2019-01-27 10:00:20 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2019-01-27 10:01:01 UTC
I really like the clean-up, but from the discussion on the main bug I understood that the token is an optional feature and you would still be allowed to search for subscriptions/reports without it (what about commenting/rating?). If that's the case it would be nice to make this more clear in the documentation of the feature.
Comment 8 Josef Moravec 2019-01-28 20:57:59 UTC
Created attachment 84503 [details] [review]
Bug 22196: Clean up Mana KB administration template

This patch makes language changes to the Mana KB administration
template, and corresponding language changes to the Web Services
preference file.

Some markup errors have been fixed:

 - Correct title and breadcrumbs, copied and pasted from another
   template
 - Add ids to form fields to match their label "for" attributes
 - Make <input>s self-closing
 - Correct class names on alert dialogs
 - Wrap text in JavaScript with _() to make it translatable

Also changed: Some language revisions to the Mana dialogs on the
Administration home page.

To test, apply the patch and go to Administration -> Share content with
Mana KB.

Test the process for enabling and configuring Mana KB. Check that
forms work correctly and that the language of instructions and labels
reads well.

Go to Administration -> System preferences -> Web services, and confirm
that the language changes to the Mana KB preference look good.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 9 Josef Moravec 2019-01-28 20:58:05 UTC
Created attachment 84504 [details] [review]
Bug 22196: (QA follow-up) Fix some typo

Fixes the typo on the admin main page.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 10 Josef Moravec 2019-01-28 20:58:09 UTC
Created attachment 84505 [details] [review]
Bug 22196: (QA follow-up) Fix some more typo

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 11 Josef Moravec 2019-02-04 13:31:25 UTC
*** Bug 22244 has been marked as a duplicate of this bug. ***
Comment 12 Nick Clemens 2019-02-04 17:46:55 UTC
Awesome work all!

Pushed to master for 19.05
Comment 13 Martin Renvoize 2019-02-11 13:43:36 UTC
An enhancement to a new feature for 19.05, not need to backport.